Функция срзнач в excel

Функция срзнач в excel

В этой статье описаны синтаксис формулы и использование функции СРЗНАЧ в Microsoft Excel.

Описание

Возвращает среднее значение (среднее арифметическое) аргументов. Например, если диапазон a1: A20 содержат числа, формула = СРЗНАЧ ( a1: A20) Возвращает среднее арифметическое этих чисел.

Синтаксис

Аргументы функции СРЗНАЧ описаны ниже.

Число1. Обязательный аргумент. Первое число, ссылка на ячейку или диапазон, для которого требуется вычислить среднее значение.

Число2. Необязательный. Дополнительные номера, ссылки на ячейки или диапазоны, для которых вычисляется среднее значение максимум в 255.

Замечания

Аргументы могут быть числами, именами или ссылками на диапазоны или ячейки, содержащие числа.

Логические значения и текстовые представления чисел, которые непосредственно введены в список аргументов, не учитываются.

Если аргумент является ссылкой на диапазон или ячейку, содержащую текст или логические значения, или ссылкой на пустую ячейку, то такие значения игнорируются; однако ячейки, которые содержат нулевые значения, учитываются.

Аргументы, являющиеся значениями ошибок или текстом, которые не могут быть преобразованы в числа, вызывают ошибки.

Если логические значения и текстовые представления чисел необходимо учитывать в расчетах, используйте функцию СРЗНАЧА.

Если требуется вычислить среднее значение только для тех значений, которые удовлетворяют определенным критериям, используйте функцию СРЗНАЧЕСЛИ или СРЗНАЧЕСЛИМН.

Примечание: Функция СРЗНАЧ вычисляет среднее значение, то есть центр набора чисел в статистическом распределении. Существует три наиболее распространенных способа определения среднего значения, описанных ниже.

Среднее значение — это среднее арифметическое, которое вычисляется путем сложения набора чисел с последующим делением полученной суммы на их количество. Например, средним значением для чисел 2, 3, 3, 5, 7 и 10 будет 5, которое является результатом деления их суммы, равной 30, на их количество, равное 6.

Медиана — это число, которое является серединой множества чисел, то есть половина чисел имеют значения большие, чем медиана, а половина чисел имеют значения меньшие, чем медиана. Например, медианой для чисел 2, 3, 3, 5, 7 и 10 будет 4.

Мода — это число, наиболее часто встречающееся в данном наборе чисел. Например, модой для чисел 2, 3, 3, 5, 7 и 10 будет 3.

При симметричном распределении множества чисел эти величины оценки степени централизации равны. При ассиметричном распределении множества чисел они могут отличаться.

Совет: При вычислении средних значений ячеек следует учитывать различие между пустыми ячейками и ячейками, содержащими нулевые значения, особенно если в диалоговом окне Параметры Excel настольного приложения Excel снят флажок Показывать нули в ячейках, которые содержат нулевые значения. Если этот флажок установлен, пустые ячейки игнорируются, но нулевые значения учитываются.

Читайте также:  Загрузочный диск для восстановления жесткого диска

Местонахождение флажка Показывать нули в ячейках, которые содержат нулевые значения

Откройте вкладку Файл , а затем нажмите кнопку Параметры и в категории Дополнительно найдите группу Показать параметры для следующего листа.

Пример

Скопируйте образец данных из следующей таблицы и вставьте их в ячейку A1 нового листа Excel. Чтобы отобразить результаты формул, выделите их и нажмите клавишу F2, а затем — клавишу ВВОД. При необходимости измените ширину столбцов, чтобы видеть все данные.

Функции СРЗНАЧ и СРЗНАЧА служат для того, чтобы вычислять среднее арифметическое значение интересующих аргументов в Excel. Среднее число вычисляется классическим путем – суммирования всех чисел и делением суммы на количество этих же чисел. Главное отличие этих функций заключается в том, что они по-разному обрабатывают не числовые типы значений, которые находятся в ячейках Excel. Далее обо всем поподробнее.

Примеры использования функции СРЗНАЧ в Excel

Функция СРЗНАЧ относится к группе «Статистические». Поэтому для вызова данной функции в Excel необходимо выбрать инструмент: «Формулы»-«Библиотека функций»-«Другие функции»-«Статистические»-«СРЗНАЧ». Или вызвать диалоговое окно «Вставка функции» (SHIFT+F3) и выбрать из выпадающего списка «Категория:» опцию «Статистические». После чего в поле «Выберите функцию:» будет доступен список категории со статистическими функциями где и находится СРЗНАЧ, а также СРЗНАЧА.

Если есть диапазон ячеек B2:B8 с числами, то формула =СРЗНАЧ(B2:B8) будет возвращать среднее значение заданных чисел в данном диапазоне:

Синтаксис использования следующий: =СРЗНАЧ(число1; [число2]; …), где первое число обязательный аргумент, а все последующие аргументы (вплоть до числа 255) необязательны для заполнена. То есть количество выбранных исходных диапазонов не может превышать больше чем 255:

Аргумент может иметь числовое значение, быть ссылкой на диапазон или массив. Текстовое и логическое значение в диапазоне полностью игнорируется.

Аргументы функции СРЗНАЧ могут быть представлены не только числами, но и именами или ссылками на конкретный диапазон (ячейку), содержащий число. Учитывается логическое значение и текстовое представление числа, которое непосредственно введено в список аргументов.

Если аргумент представлен ссылкой на диапазон (ячейку), то его текст или логическое значение (ссылка на пустую ячейку) игнорируется. При этом ячейки, которые содержат нуль, учитываются. Если аргумент содержит ошибки или текст, который не может быть преобразован в число, то это приводит к общей ошибке. Для учета логических значений и текстового представления чисел необходимо в расчетах использовать функцию СРЗНАЧА, о которой пойдет разговор дальше.

Читайте также:  Тор браузер не устанавливается

Результат выполнения функции в примере на картинке ниже – это число 4, т.к. логические и текстовые объекты игнорируются. Поэтому:

(5 + 7 + 0 + 4) / 4 = 4

При вычислениях средних значений необходимо учитывать разницу между пустой ячейкой и ячейкой, содержащей нулевое значение, особенно если в диалоговом окне Excel снят флажок «Показывать нули в ячейках, которые содержат нулевые значения». Когда флажок установлен, пустые ячейки игнорируются, а нулевые значения нет. Чтобы снять или установить этот флаг необходимо открыть вкладку «Файл», далее нажать на «Параметры» и выбрать в категории «Дополнительно» группу «Показать параметры для следующего листа», где возможно установить флажок:

Результаты еще 4-х задач сведены в таблицу ниже:

Как видно на примере, в ячейке A9 функция СРЗНАЧ имеет 2 аргумента: 1 — диапазон ячеек, 2 – дополнительное число 5. Так же могут быть указаны в аргументах и дополнительные диапазоны ячеек с числами. Например, как в ячейке A11.

Формулы с примерами использования функции СРЗНАЧА

Функция СРЗНАЧА отличается от СРЗНАЧ тем, что истинное логическое значение «ИСТИНА» в диапазоне приравнивается к 1, а ложное логическое значение «ЛОЖЬ» или текстовое значение в ячейках приравнивается к нулю. Поэтому результат вычисления функции СРЗНАЧА отличается:

Результат выполнения функции возвращает число в примере 2,833333, так как текстовые и логические значения приняты за нуль, а логическое ИСТИНА приравнено к единице. Следовательно:

(5 + 7 + 0 + 0 + 4 + 1) / 6 = 2,83

Аргументы функции СРЗНАЧА подчинены следующим свойствам:

  1. «Значение1» является обязательным, а «значение2» и все значения, которые следуют за ним необязательными. Общее количество диапазонов ячеек или их значений может быть от 1 до 255 ячеек.
  2. Аргумент может быть числом, именем, массивом или ссылкой, содержащей число, а также текстовым представлением числа или логическим значением, например, «истина» или «ложь».
  3. Логическое значение и текстовое представление числа, введенного в список аргументов, учитывается.
  4. Аргумент, содержащий значение «истина», интерпретируется как 1. Аргумент, содержащий значение «ложь», интерпретируется как 0 (ноль).
  5. Текст, содержащийся в массивах и ссылках, интерпретируется как 0 (ноль). Пустой текст («») интерпретирован тоже как 0 (ноль).
  6. Если аргумент массив или ссылка, то используются только значения, входящие в этот массив или ссылку. Пустые ячейки и текст в массиве и ссылке — игнорируется.
  7. Аргументы, которые являются значениями ошибки или текстом, не преобразуемым в числа, вызывают ошибки.
Читайте также:  Intel core i5 7500 тест

Результаты особенности функции СРЗНАЧА сведены в таблицу ниже:

Внимание! При вычислениях средних значений в Excel надо учитывать различия между пустой ячейкой и ячейкой, содержащей нулевое значение (особенно если в диалоговом окне «Параметры» снят флажок «Показывать нули в ячейках, которые содержат нулевые значения»). Когда флажок установлен, пустые ячейки не учитываются, а нулевые значения учитываются. Для установки флажка на вкладке «Файл» надо выбрать команду «Параметры», перейти в категорию «Дополнительно», где найди раздел «Показать параметры для следующего листа» и там установить флаг.

При подготовке к ГИА по информатике для успешного решения задачи 19 из части 3 необходимо знать некоторые функции Excel. Одна из таких функций — СРЗНАЧ. Рассмотрим ее подробнее.

Функция СРЗНАЧ Excel позволяет найти среднее арифметическое аргументов. Синтаксис этой функции такой:

Не забываем, что ввод формулы в ячейку начинается со знака «=».

В скобках мы можем перечислить числа, среднее значение которых хотим найти. К примеру, если мы напишем в ячейке =СРЗНАЧ(1; 2; -7; 10; 7; 5; 9), то получим 3,857142857. Это легко проверить — если мы сложим все числа в скобках (1 + 2 + (-7) + 10 + 7 + 5 + 9 = 27) и разделим на их количество ( 7 ), то получим 3,857142857142857.

Обратите внимание — числа в скобках разделяются точкой с запятой (;). Таким образом мы можем указать до 255 чисел.

Для примеров я использую Microsort Excel 2010.

Кроме того, с помощью функции СРЗНАЧ мы можем найти среднее значение диапазона ячеек. Предположим, что у нас в диапазоне A1:A7 хранятся некоторые числа, и мы хотим найти их среднее арифметическое.

Давайте поместим в ячейку B1 среднее арифметическое диапазона A1:A7. Для этого устанавливаем курсор в ячейку B1 и пишем =СРЗНАЧ(A1:A7). В скобках я указал диапазон ячеек. Обратите внимание, что разделителем является символ двоеточие (:). Можно было бы поступить еще проще — написать в ячейке B1 =СРЗНАЧ( , а далее мышкой выделить нужный диапазон.

В итоге в ячейке B1 мы получим число 15,85714286 — это и есть среднее арифметическое диапазона A1:A7.

Excel среднее значение диапазона

В качестве разминки предлагаю найти среднее значение чисел от 1 до 100 (1, 2, 3 и т.д. до 100). Первый ответивший в комментариях правильно получит 50р на телефон Работаем.

Автор: Александр Чернышов

Оцените статью, это очень поможет развитию сайта.

Ссылка на основную публикацию
Adblock detector